全站导航
当前位置:我的世界中文网 > 常用工具 > 我的世界自定义脚本生成器
我的世界自定义脚本生成器
0 0
我的世界自定义脚本生成器

等级:

类型:常用工具

更新:2021/1/16 17:17:47

文件:hbb

语言:中文

软件介绍

我的世界自定义脚本生成器是一由广大网友自行制作的游戏辅助工具,可以在线自定义各种脚本,如拔刀剑脚本、npc脚本、建筑脚本等,生成模组十分方便,有需要的玩家们快来下载体验吧!

我的世界自定义脚本生成器简介

我的世界自定义脚本生成器AutoSpawnZScript是一款由论坛网友制作分享的游戏工具,它的功能十分强大,可以自定义制作想要的脚本,可以设置不同的对象,创建模组,支持云端保存功能,感兴趣的朋友快来下载体验吧。

我的世界自定义脚本生成器是一由广大网友自行制作的游戏辅助工具

我的世界自定义脚本生成器功能

20201126 AutoSpawnZScript v0.1

添加 模拟工作台配方合成方式

添加 在难度模式下部分常用配方列表

添加 配方ID支持图片显示和中文名称

自定义配方英文名称

添加 代码生成日志显示

添加 脚本生成

20201128 AutoSpawnZScript v0.2

我的世界自定义脚本生成器是一由广大网友自行制作的游戏辅助工具

添加 合成数量

添加 清空文本

添加 帮助信息

20201128 AutoSpawnZScript v0.3

添加 物品所属配方列表

添加 配方列表所属方块

修复 多行代码生成到文件只有一行的问题

添加了更多的资源列表

20201129 AutoSpawnZScript - v0.4

修改了多条配方写到文件不换行的问题

添加 自定义配方小故事

20201216 AutoSpawnZScript - v1.0

预设了 11 个资源文件未同步到程序中

添加了 12 种无序配方合成模板

添加了使用说明和依赖环境说明其他一些说明

事实上当前版本已经实现了所有预设功能,剩下的对无序配方做了一些细节优化

我的世界自定义脚本生成器生成器代码

版本 2

.局部变量 层级目录, 文本型

.局部变量 脚本文件名, 文本型

.局部变量 文件号, 整数型

.局部变量 计数器, 整数型

输入框 (“请输入当前配方文件名”, “信息”, , 脚本文件名, 1, _启动窗口)

层级目录 = 编辑框11.内容 + “\scripts\” + 脚本文件名 + “.zs”

' 创建脚本文件

写到文件 (层级目录, 到字节集 (“”))

' 打开文件

文件号 = 打开文件 (层级目录, , )

' 写出文本 (文件号, 代码集) 写出配方代码, 脚本信息

.计次循环首 (取数组成员数 (代码集), 计数器)

写出文本 (文件号, 到文本 (代码集 [计数器]))

.计次循环尾 ()

使用说明程序没有做容错处理,你需要谨慎的输入来避免错误的出现.

箭头左侧的九宫格为合成所需材料,右侧是想要合成的物品

配方小故事和配方名称可以为空

数量为空时默认为1

游戏原所属物品必须选中物品所属ID中的 minecraft:,配方所属块也必须选择为 craftingTable

目前配方所属块中的 furnace 无法使用

物品所属块ID中的 tinymobfarm 所支持的物品为 xxx_farm

在首次使用时必须选中一次 选项 - 有序配方表,否则生成的代码为空

生成的脚本文件中不支持中文

.minecraft文件夹路径 这里必须选择你的游戏目录,确保当前目录 scripts 目录存在.参考示例:

正确的输入 F:\game\Minecraft\HMCL\.minecraft

错误的输入 F:\game\Minecraft\HMCL\.minecraft\scripts

菜单栏中的选项下的 无序配方表,熔炉配方表 和 主题 目前还没有实现功能,所以点了也没用

选中右侧列表框中的项目然后在左侧的九宫格中按下回车表示快速输入当前选择项,按下空格来使用泥土代表空项.

当前程序所支持的配方正好又100个,如果你想添加程序中不存在的配方你可以手动在九宫格中输入物品ID,当然不排除有很多独立 mod 它们的 物品所属ID 和 配方所属块 在程序中无法添加,这种情况下你可以用文本编辑器来批量替换这些默认已有的关键字一样可以解决问题

点击展开全部
CopyRight © 2013年-2021年 All Rights Reserved